HomeHome ArchiveArchive

webalizer for woody linked against libgd2 from agrogeomatic.educagri.fr

Here is a webalizer package compiled for Debian woody i386 compatible systems and linked against the libgd2 library from AgreomaTIC. The reason why I had to recompile webalizer is that woody’s webalizer links against libgd2 and versions 1.0.12 of libpng2. The “new” libgd2 libray from AgreomaTIC links against libpng12-0 version 1.2.5.0-4 which will make the linker become all uneasy and spit out errors like the following:

        libpng warning: Application was compiled with png.h from libpng-1.2.5
        libpng warning: Application  is running with png.c from libpng-1.0.12
        gd-png:  fatal libpng error: Incompatible libpng version in application and library

The webalizer package is a hacked backport of webalizer in Debian unstable. Since unstable has introduced some new functionality in the gettext library which webalizer uses I had to hack that out from webalizer in order to make it compile with woody’s gettext. Please see the diff.

Enjoy! Tomas Pospisek