HomeHome ArchiveArchive

killing deprecation warning of rubygems 1.7.x

There might be a reason to upgrade to rubygems 1.7.x, however if you have done so by misstake and find your console swamped by thousands of deprecation warnings:

NOTE: Gem::Specification#default_executable= is deprecated with no replacement. It will be removed on or after 2011-10-01.

and you’re crying desperately for help, then you might try the following very ugly hack, which you should revert at some point in time:

First look where your rubygems are installed:

$ gem list -d rubygems

Find the deprecate.rb file there, and make the def self.skip class method allways return true. That’s it. Happy hacking on. And don’t forget, that you’ll need to undo this change sometime!

Tomáš Pospíšek